Site-of-Origin(SOO) in BGP vs Site-of-Origin(SOO) in EIGRP

假設R1,R2這兩個PE之間有IBGP連線,為了避免loop因此設定SOO來辨識路由內容:

R1(config)#route-map BGP_SOO permit 10
R1(config-route-map)#set extcommunity soo 65001:1
R1(config)#router bgp 100
R1(config-router)#address-family ipv4 vrf SITE1
R1(config-router-af)#neighbor 2.2.2.2 route-map BGP_SOO in

R2(config)#route-map BGP_SOO permit 10
R2(config-route-map)#set extcommunity soo 65001:1
R2(config)#router bgp 100
R2(config-router)#address-family ipv4 vrf SITE2
R2(config-router-af)#neighbor 1.1.1.1 route-map BGP_SOO in




假設R1,R2之間為EIGRP neighbor,在兩個router上的interface設定SOO:

R1(config)#route-map EIGRP_SOO permit 10
R1(config-route-map)#set extcommunity soo 300:1
R1(config)#int f0/0.1
R1(config-if)#ip vrf sitemap EIGRP_SOO

R2(config)#route-map EIGRP_SOO permit 10
R2(config-route-map)#set extcommunity soo 300:1
R2(config)#int f0/0.1
R2(config-if)#ip vrf sitemap EIGRP_SOO
Post a Comment

Popular posts from this blog

Pairwise Master Key (PMK) vs Parewise Transient Key(PTK) vs PseudoRandom Function(PRF) vs GTK (Groupwise Transient Key)

DSSS(直接序列展頻技術) vs OFDM(正交頻率多重分割)

DTMF Relay : RTP-NTE vs SIP INFO vs SIP NOTIFY