Posts

TCP/IP 明確擁塞通知 (ECN)

Image
當路由器擁塞的程度已經達到填滿傳入封包緩衝區而開始捨棄封包時,會影響網路而縮減頻寬,對資料損失敏感或具時效性的傳輸量流動會進而受到衝擊,而且可能在擁塞之後產生連結閒置時間。TCP/IP 明確擁塞通知 (ECN) 讓路由器能夠通知「傳輸控制通訊協定」(TCP) 對等體,由於網路擁塞,緩衝區已滿。TCP 對等體會以減緩資料傳輸來回應,協助防止封包損失。 明確擁塞通知(Explicit Congestion Notification) TCP/IP 的 ECN 支援同時使用 IP 及 TCP 標頭中的未使用位元。 • 在 (IP) 網際網路層上,轉送封包時,傳送主機必須能夠表示有能力執行 ECN,而路由器則必須能夠指出所遇到的擁塞狀況。 • 在 (TCP) 傳輸層,TCP 對等體必須彼此表明有能力執行 ECN。接收端對等體必須能夠通知傳送端對等體,已經從遇到擁塞狀況的路由器接到封包;傳送端對等體必須能夠通知接收端對等體,已經從接收端對等體接到擁塞指標,並且已經降低傳輸速率。 IP 中的 ECN 支援 IP 標頭中的 8 位元 [Type of Service (TOS)] 欄位最先定義於 RFC 791 中,指出封包由路由器進行非預設傳送的傳送優先順序、延遲、輸送量、可靠性,以及成本等特性。TOS 欄位在 RFC 2474 中重新定義,以包含 6 位元區別服務代碼點 (Differentiated Services Code Point, DSCP) 及兩個未使用的位元。DSCP 值表示的傳送優先順序會對應於先前在內部網路的路由器中設定的佇列。IP 中的 ECN 支援使用 RFC 2474 所定義 TOS 欄位的兩個未使用位元。[圖 1] 顯示 ECN 中 TOS 欄位的新定義。 圖 1:ECN 中 TOS 欄位的新定義 RFC 2474 所定義 TOS 欄位中的兩個未使用位元在 RFC 3168 中定義為 ECN 欄位,欄位的值如下: • 00 傳送主機不支援 ECN。 • 01 或 10 傳送主機支援 ECN。 • 11 路由器已遇到擁塞狀況。 具備 ECN 功能的主機傳送其封包時,會將 ECN 欄位設定為 01 或 10。對於具備 ECN 功能的主機所傳送的封包,如果路徑中的路由器具備 ECN 功能,但是正遇到擁塞狀況,則 ECN 欄位會設定為 11。一旦 ECN ...

靜電放電(Electrostatic Discharge,ESD)

靜電放電(Electrostatic Discharge,ESD)是電子設備在連接過程中出現的主要問題之一,它會造成許多電子元件或電子系統失效,使得電子設備製造商蒙受不少損失。加上多功化及小型化已成為目前手持產品設計的趨勢,然而當這些手持產品被要求提供多功能時,其I/O埠也隨之增多,容易導致ESD進入系統,進而干擾或損壞積體電路。 而ESD破壞產生的原因,除了人為因素外,電子元件本身也會累積靜電。如何採取有效的措施來防治與因應,對電子設備製造商而言,將是刻不容緩的問題。此外,設計人員應在設計階段就宜遵循ESD標準中提出的要求,考慮到設備應當具備有效和可靠的ESD保護措施,使得IC盡可能提供最有效的ESD保護,同時還要讓額外的保護元件不佔用太多機板空間和成本,最重要的是不能干擾元件功能。

DAS vs NAS vs SAN

DAS(Direct Attached Storage)直接連接存儲 DAS即直連方式存儲,英文全稱是Direct Attached Storage。中文翻譯成“直接附加存儲”。顧名思義,在這種方式中,存儲設備是透過電纜(通常是SCSI接口電纜)直接到伺服器的。I/O(輸入/輸入)請求直接發送到存儲設備。DAS,也可稱為SAS(Server-Attached Storage,伺服器附加存儲)。它依賴於伺服器,其本身是硬體的堆疊,不帶有任何存儲作業系統。 DAS直接連接存儲已經遠遠不能滿足企業的需求。對於多個伺服器或多台PC的環境,使用DAS方式設備的初始費用可能比較低,可是這種連接方式下,每台PC或伺服器單獨擁有自己的存儲磁碟,容量的再分配困難;對於整個環境下的存儲系統管理,工作煩瑣而重複,沒有集中管理解決方案。所以整體的擁有成本(TCO)較高。由於單台電腦對數據遠遠不能滿足企業對數據的要求,這種連接方式已經在企業的解決方案中甚少被採用了。 NAS(Network Attached Storage)網路連接儲存 NAS是由Network Appliance公司最先推出的網路儲存技術。簡單地說,NAS儲存技術可讓不同平台的多個使用者透過專業伺服器存取資料檔案。 NAS在乙太網路上,以IP協定為基礎,透過專門的檔案伺服器管理區域網路上的資訊流,提供各種不同的伺服器、工作站之間共通的資料儲存協定。由於該伺服器專司資料存取動作,使其他的伺服器不需分配額外的空間來處理,得以有更多的空間去處理其他的指令。NAS最大的特色在於可將儲存空間分配在不同的伺服器或工作站,讓資料檔案以分享型態在網路上使用,此外,NAS可跨平台使用。NAS只能以檔案的方式個別傳輸,不像SAN可以資料區塊的方式傳送。 SAN(Storage Area Network)儲存區域網路 顧名思義是由儲存設備、主機、工作站所構成的網路,傳統的區域網路(Local Area Network)上的工作站必須經過 LAN至主機上讀取資料,所以就會受限於網路頻寬與伺服器的速度,而無法提供更高的速度,而 SAN 為利用 Fibre Channel 的架構提供多儲存設備、主機、工作站所構成的網路,因為儲存設備、主機、工作站直接連接故主機(或工作站)可不經伺服器直接存取資料,此種由原 server-based 主機端轉變至控制器...

軟交換技術詳解 軟交換技術中的分組協議

發佈時間:2008.01.31 05:03 來源:賽迪網-技術社區 作者:薩德 在通信系統中,控制通過協商實現,因此必須有相應的協議。在NGN體系結構中,軟交換是控制中心,它支援H.248/MeGaCo、SIP、MGCP、H.323等多秤協議。 1 MGCP協議 1.1MGCP基本概念 MGCP協議與H.223和SIP不同,H.323和SIP提出兩套IP電話體系結構,二者完全獨立,不能互相相容,只能互通。MGCP不涉及IP電話的體系結構,只涉及網關分解問題,因而不僅可用於H.323IP電話系統,也可用於SIP IP電話系統。網關可分解成媒體網關(MG)和媒體網關控制器(MGC),MG在 MGC(或軟交換)的控制下,實現跨網媒體業務。從邏輯上看很簡單,網關由 MG和MGC組成。從物理上看就不那麼簡單了,到目前為止,網關的分解還沒有確定的方式,可根據不同的需求進行分解。   MGCP協議是1999年由Internet工程任務組(IETF)制定的媒體網關控制協議,MGCP協議定義的連接模型包括端點(endpoint)和連接(connection)兩個主要概念。端點是數據源或數據宿,可以是物理端點,也可以是虛擬端點。端點類型包括數字通道、模擬線、錄音伺服器接入點及互動式話音響應接入點。端點標識由端點所在網關域名和網關中的本地名兩部分組成。連接可以是點到點連接或多點連接。點到點連接是兩個互相發送數據的端點之間的一種關聯,該關聯在兩個端點都建立起來後,就可開始傳送數據。多點連接是多個端點之間的聯。連接可建在不同類型的承載網路上。呼叫代理可要求端點在檢測到某些事件(如摘機、挂機、拍叉或撥號)發生時,向其發出通知,也可請求將某些信號(如撥號音、回鈴音、忙音等)加到端點上。事件和信號組合成包,每個包由某一特定端點支援。每個事件(含信號)可用“包名/事件名”表示,每類端點有特定的包,每個包包含有規律的事件和信號,包名和事件名均用數字字母串表示。 1.2協議結構及命令 MGCP採用文本協議,協議消息分為命令和響應,每個命令需要接收方回送響應,採用三次握手方式證實。命令消息由命令行和若干參數行組成,響應消息帶有3位數字的響應碼。MGCP採用媒體描述協議(SDP)向網關描述連接參數。為了減小信令傳送時延,MGCP採用用戶數據報協議(UDP)傳送。協議命令包括: (l)端點配置命...

【超合金魂】GX-07E LIMITED 無敵鐵金剛 - ENERGER-Z(限定3000個)

Image
回首過去,這已經不知是第幾隻入手的玩具,原本小朋友的房間已經變成我個人的玩具收藏室,記得剛開始收集時,那時超合金魂剛出到GX-02,單身的日子枯燥無味,看到小時候心目中的偶像,趁著每個月手上的閒錢尚未有預定歸宿時,開始踏上這條不歸路。 這隻無敵鐵金剛如果各位是第一次接觸到超合金魂,可能心中會出現一段OS "怎麼長得這麼醜啊,這樣的玩具有人要買嘛?" 哈,這個觀點,說實在以我這個Fans來說也會有那麼一點的同感,不過很多的東西就是看特色,這款超合金的最大特色就是它不同於以往的造型,這是原作者永井豪在魔神天使漫畫中的手稿模型,最可愛的一點就是如附圖的樣子,組合艇(應該不能叫組合艇,要叫組合機車了)不是用飛的,而是用爬的喔,我想大多數的人一定會笑出來,甚至還有專屬階梯出現…。 而且"限定"這兩個字通常對於超合金魂系列玩具來說"大都"具有保值的意思(有時BANDAI會不按牌理出牌,限定數量賣完又再加注生產..對於買貴的同好來說只能搥心肝以洩忿。),最可怕的漲幅莫過於GX-01RB,由於是日本國內DVD通信抽獎限定(買了無敵鐵金剛動畫DVD之後再把回函寄回參加抽獎),所以非常難入手,就算入手玩家也不會轉售(除非是玩具炒手或店家),市值至少在台幣兩萬五到五萬之間(請小心不要噴飯,我沒有寫錯字!)。 這款GX-07E是日本永井豪40週年展會場限定產品,所以拜"限定"二字之賜,當我入手時市價已經翻了兩三倍以上,甚至有人賣到NT$4500~5000之譜(原價約日幣$4500左右)。 有時買玩具會成為一種習慣,不是因為喜歡這個玩具,只是因為它屬於小時候夢想的一部份,小時候家裏沒有很多錢,不太可能想要什麼玩具就可以買,像這類大合金高單價玩具,我只擁有過一個五獅百獸王,但是已經非常滿足。我想有很多五、六字頭的人都是收集超合金魂的主力客戶,因為那個時代的夢想現在剛好有辦法完成,再加上物以稀為貴的想法(超合金魂除了少部份系列有不斷複刻之外,大部份只在某一段時期生產,然後就不再出現),很多人就這樣一邊餓肚子一邊跑玩具店在這條玩具收集的道路上持續前進,再有錢一點的時候,連買房子都要想到玩具要放在那。 隨著經濟壓力及年紀的增長,很多人慢慢地不再這麼堅持,陸陸續續改變買玩具的方式(買玩具的次數變少或是縮小收集的範圍)。所...

總是在農曆過年前後報到的電腦詛咒…

去年的農曆新年是一段難忘的年假…為什麼?因為整個年假都在進行零組件測試,主機不明原因無法過電(後來我老婆告訴了我原因,我兒子把Power/Reset當電動玩具在不斷地進行壓力測試…後來就突然再起不能),一開始猜測是電力不夠,所以把所有能下線的先下線,不過還是沒有用,因此猜測是主機板掛了,跑去買了一張新的主機板+CPU+RAM(因為原有的CPU太舊了已經買不到相對應的主機板了),結果仍然無效???心中一股寒意,難不成要我換整套???,最後狠下心了,只好連Case也全部換新。 買來了所有的新零組件,心中仍不死心,一定要給他找出問題來,最後終於找到問題,原來是Power Supply掛了… 因此就這樣過完了我的上一個年假…好悲情的年假,年假沒了,錢也沒了~ 好死不死,今年又要過年假了,這個星期一老婆打電話到我公司來說,"老公,家裏的電腦好像怪怪的"(我最怕聽到這樣形容詞的,就好像老人家跟醫生說身體不舒服,但又說不出來那裏有毛病…),心中又是一凜,難不成是詛咒,而且還是很準時報到的詛咒…詳細地詢問之下,不但電腦按Power沒有通電而且還有戴奧辛的味道,這時我大概知道要準備花多少錢了,不是主機板掛就是CPU掛,這次我比較不擔心Power掛了,因為上次的經驗,我上次特地花大錢買了好機絲!(主動式PFC模組化500W) 後來回到家中二話不說直接先把電腦解體(有點像是解剖命案屍體找兇手的感覺),經過單獨Power Supply測試,果然頭好壯壯一如往常,把主機板拆下來仔細檢查,真的在1394跳腳附近燒黑了一塊,還有焦黑後的灰燼…心中盤算著如果只有主機板自爆不傷及無辜最好,如果不小心波及其他至親的話,…那就完蛋了,年終獎金又要準備直接從手中離去。 接下來這幾天就開始進去無止盡的循環,先買了主機板替換測試,很興奮地把AMD 64 X2很努力地拔下來(隨著時代的進步CPU愈來愈難拆,以後386時代超級簡單的事情,沒有想到CPU一直進步,風扇的安裝卻是難如登天),再很努力地裝到新的主機板上。很高興的事出現了,終於正常聽到好久不見的"嗶"聲,真是感動莫名。 不過最難的考驗現在才開始,開機之後一直有一個問題,就是原來的SATA 250G系統碟看不到,明明就有接著電源及訊號線但是在BIOS中就是沒有,不管三七二十一,先開始把WindowsXP裝起來再說,就...

Introducing Cisco Certified Design Expert (CCDE) Certification

Introducing Cisco Certified Design Expert (CCDE) Certification Responding to strong customer demand to assess and recognize Sr. Level Network Architecture skills in the market, Cisco is introducing a new premiere knowledge based certification focused on Network Infrastructure Design. - The Cisco Certified Design Expert (CCDE). The CCDE is an expert-level certification with content emphasis on expertise in network architecture, which is the capstone for Cisco’s design curriculum. In addition, passing the CCDE certification demands competencies of an experienced, seasoned, networking professional with a proven ability to interface with customers at the executive-level to ensure that business requirements are incorporated into successful designs. What is a CCDE? The successful CCDE-certified individual must have a demonstrated an ability to analyze and develop solutions which address planning, design, integration, optimization, operations, security and on-going support focused at the infr...