[POC] Cisco vs Juniper running OSPF w/o Backbone Area 0
As everyone knows that OSPFv2 is a standard routing protocol (http://www.ietf.org/rfc/rfc2328.txt), but not all vendors device will implement it exactly the same. Especially when the network scenario was not follow the standard design, then it might have different exceptional behavior in different vendor devices.
In order to compare the difference behavior between Cisco and Juniper. I designed a special OSPF topology just like below, so we can see Cisco and Juniper have different result of routing exchange behavior.
Building configuration...
Current configuration : 1144 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 1
network 10.1.1.0 0.0.0.3 area 1
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
R1#sh ip ospf database
OSPF Router with ID (10.1.1.1) (Process ID 1)
Router Link States (Area 1)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 882 0x80000003 0x005AA9 1
10.1.1.1 10.1.1.1 903 0x80000003 0x00CB31 1
Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
10.1.1.1 10.1.1.1 903 0x80000002 0x003ECE
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
100.100.100.0 10.1.1.6 697 0x80000002 0x003A26 0
R2#sh run
Building configuration...
Current configuration : 1297 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
ip address 10.1.1.5 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
redistribute static subnets
network 2.2.2.2 0.0.0.0 area 2
network 10.1.1.0 0.0.0.3 area 1
network 10.1.1.4 0.0.0.3 area 2
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
100.0.0.0/24 is subnetted, 1 subnets
O E2 100.100.100.0 [110/20] via 10.1.1.6, 00:51:05, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.1.1.6, 00:51:05, FastEthernet0/1
10.0.0.0/30 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
C 10.1.1.4 is directly connected, FastEthernet0/1
R3#sh run
Building configuration...
Current configuration : 1295 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.1.1.6 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
redistribute static subnets
network 3.3.3.3 0.0.0.0 area 2
network 10.1.1.4 0.0.0.3 area 2
!
ip classless
ip route 100.100.100.0 255.255.255.0 Null0
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.1.1.5, 00:52:24, FastEthernet0/0
100.0.0.0/24 is subnetted, 1 subnets
S 100.100.100.0 is directly connected, Null0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.4 is directly connected, FastEthernet0/0
lab# show logical-systems R1
interfaces {
em1 {
unit 12 {
vlan-id 12;
family inet {
address 10.1.1.1/30;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.1 {
interface em1.12;
interface lo0.1;
}
}
}
In order to compare the difference behavior between Cisco and Juniper. I designed a special OSPF topology just like below, so we can see Cisco and Juniper have different result of routing exchange behavior.
Cisco IOS (GNS3)
When we are using Cisco device with IOS to simulate this topology:
R1#sh running-config- R1 will not receive any routes. But if you check the R1 OSPF database, actually, you still see that LSA type 5 was received from R2, even R2 is not an ABR(because it has no backbone area 0).
- R2 will learn all routes because it belong to both OSPF areas.
- R3 will only learn all routes which was belong to area 2.
Building configuration...
Current configuration : 1144 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 1
network 10.1.1.0 0.0.0.3 area 1
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
R1#sh ip ospf database
OSPF Router with ID (10.1.1.1) (Process ID 1)
Router Link States (Area 1)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 882 0x80000003 0x005AA9 1
10.1.1.1 10.1.1.1 903 0x80000003 0x00CB31 1
Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
10.1.1.1 10.1.1.1 903 0x80000002 0x003ECE
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
100.100.100.0 10.1.1.6 697 0x80000002 0x003A26 0
R2#sh run
Building configuration...
Current configuration : 1297 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
ip address 10.1.1.5 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
redistribute static subnets
network 2.2.2.2 0.0.0.0 area 2
network 10.1.1.0 0.0.0.3 area 1
network 10.1.1.4 0.0.0.3 area 2
!
ip classless
!
no ip http server
!
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
100.0.0.0/24 is subnetted, 1 subnets
O E2 100.100.100.0 [110/20] via 10.1.1.6, 00:51:05, FastEthernet0/1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.1.1.6, 00:51:05, FastEthernet0/1
10.0.0.0/30 is subnetted, 2 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
C 10.1.1.4 is directly connected, FastEthernet0/1
R2#sh ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 1)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 1315 0x80000003 0x005AA9 1
10.1.1.1 10.1.1.1 1338 0x80000003 0x00CB31 1
Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
10.1.1.1 10.1.1.1 1338 0x80000002 0x003ECE
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 1315 0x80000004 0x00DC06 2
10.1.1.6 10.1.1.6 1130 0x80000005 0x00794F 2
Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.5 2.2.2.2 1315 0x80000002 0x00A365
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
100.100.100.0 10.1.1.6 1130 0x80000002 0x003A26 0
R3#sh run
Building configuration...
Current configuration : 1295 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
!
!
ip tcp synwait-time 5
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
no clns route-cache
!
interface FastEthernet0/0
ip address 10.1.1.6 255.255.255.252
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
no clns route-cache
!
router ospf 1
log-adjacency-changes
redistribute static subnets
network 3.3.3.3 0.0.0.0 area 2
network 10.1.1.4 0.0.0.3 area 2
!
ip classless
ip route 100.100.100.0 255.255.255.0 Null0
!
no ip http server
!
!
!
!
!
!
control-plane
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
!
end
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.1.1.5, 00:52:24, FastEthernet0/0
100.0.0.0/24 is subnetted, 1 subnets
S 100.100.100.0 is directly connected, Null0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.4 is directly connected, FastEthernet0/0
R3# sh ip ospf database
OSPF Router with ID (10.1.1.6) (Process ID 1)
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 1387 0x80000004 0x00DC06 2
10.1.1.6 10.1.1.6 1200 0x80000005 0x00794F 2
Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
10.1.1.5 2.2.2.2 1387 0x80000002 0x00A365
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
100.100.100.0 10.1.1.6 1200 0x80000002 0x003A26 0
Juniper JUNOS(olive)
When we are using Juniper device with JUNOS to simulate the same topology:
- R1 will receive all routes. Just like we still have OSPF backbone area 0.
- R2 will learn all routes because it belong to both OSPF areas.
- R3 will receive all routes. Just like we still have OSPF backbone area 0.
lab# show logical-systems R1
interfaces {
em1 {
unit 12 {
vlan-id 12;
family inet {
address 10.1.1.1/30;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.1 {
interface em1.12;
interface lo0.1;
}
}
}
lab# run show route logical-system R1
inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32 *[Direct/0] 02:19:11
> via lo0.1
2.2.2.2/32 *[OSPF/10] 00:03:01, metric 1
> to 10.1.1.2 via em1.12
3.3.3.3/32 *[OSPF/10] 00:03:01, metric 2
> to 10.1.1.2 via em1.12
10.1.1.0/30 *[Direct/0] 00:03:46
> via em1.12
10.1.1.1/32 *[Local/0] 00:03:46
Local via em1.12
10.1.1.4/30 *[OSPF/10] 00:03:01, metric 2
> to 10.1.1.2 via em1.12
100.100.100.0/24 *[OSPF/150] 00:03:01, metric 0, tag 0
> to 10.1.1.2 via em1.12
224.0.0.5/32 *[OSPF/10] 02:13:34, metric 1
MultiRecv
[edit]
lab# run show ospf database detail logical-system R1
OSPF database, Area 0.0.0.1
Type ID Adv Rtr Seq Age Opt Cksum Len
Router *1.1.1.1 1.1.1.1 0x8000001b 206 0x22 0x2eb3 48
bits 0x0, link count 2
id 10.1.1.2, data 10.1.1.1, Type Transit (2)
Topology count: 0, Default metric: 1
id 1.1.1.1, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.2
Metric: 1, Bidirectional
Router 2.2.2.2 2.2.2.2 0x8000001b 207 0x22 0x31ba 36
bits 0x1, link count 1
id 10.1.1.2, data 10.1.1.2, Type Transit (2)
Topology count: 0, Default metric: 1
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.2
Metric: 1, Bidirectional
Network 10.1.1.2 2.2.2.2 0x80000004 207 0x22 0x1404 32
mask 255.255.255.252
attached router 2.2.2.2
attached router 1.1.1.1
Topology default (ID 0)
Type: Transit, Node ID: 1.1.1.1
Metric: 0, Bidirectional
Type: Transit, Node ID: 2.2.2.2
Metric: 0, Bidirectional
Summary 2.2.2.2 2.2.2.2 0x80000004 2007 0x22 0xea3f 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 0
Summary 3.3.3.3 2.2.2.2 0x80000003 207 0x22 0xc85d 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 1
Summary 10.1.1.4 2.2.2.2 0x80000009 211 0x22 0x73ab 28
mask 255.255.255.252
Topology default (ID 0) -> Metric: 1
ASBRSum 3.3.3.3 2.2.2.2 0x80000003 207 0x22 0xba6a 28
mask 0.0.0.0
Topology default (ID 0) -> Metric: 1
OSPF AS SCOPE link state database
Type ID Adv Rtr Seq Age Opt Cksum Len
Extern 100.100.100.0 3.3.3.3 0x80000002 1245 0x22 0x86f1 36
mask 255.255.255.0
Topology default (ID 0)
Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
[edit]
lab# show logical-systems R2
interfaces {
em2 {
unit 12 {
vlan-id 12;
family inet {
address 10.1.1.2/30;
}
}
unit 23 {
vlan-id 23;
family inet {
address 10.1.1.5/30;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.1 {
interface em2.12;
}
area 0.0.0.2 {
interface lo0.2;
interface em2.23;
}
}
}
[edit]
lab# run show route logical-system R2
inet.0: 9 destinations, 9 routes (9 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32 *[OSPF/10] 00:04:47, metric 1
> to 10.1.1.1 via em2.12
2.2.2.2/32 *[Direct/0] 02:20:57
> via lo0.2
3.3.3.3/32 *[OSPF/10] 00:04:51, metric 1
> to 10.1.1.6 via em2.23
10.1.1.0/30 *[Direct/0] 00:05:32
> via em2.12
10.1.1.2/32 *[Local/0] 00:05:32
Local via em2.12
10.1.1.4/30 *[Direct/0] 00:05:32
> via em2.23
10.1.1.5/32 *[Local/0] 00:05:32
Local via em2.23
100.100.100.0/24 *[OSPF/150] 00:04:51, metric 0, tag 0
> to 10.1.1.6 via em2.23
224.0.0.5/32 *[OSPF/10] 02:15:20, metric 1
MultiRecv
[edit]
lab# run show ospf database detail logical-system R2
OSPF database, Area 0.0.0.1
Type ID Adv Rtr Seq Age Opt Cksum Len
Router 1.1.1.1 1.1.1.1 0x8000001b 255 0x22 0x2eb3 48
bits 0x0, link count 2
id 10.1.1.2, data 10.1.1.1, Type Transit (2)
Topology count: 0, Default metric: 1
id 1.1.1.1, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.2
Metric: 1, Bidirectional
Router *2.2.2.2 2.2.2.2 0x8000001b 254 0x22 0x31ba 36
bits 0x1, link count 1
id 10.1.1.2, data 10.1.1.2, Type Transit (2)
Topology count: 0, Default metric: 1
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.2
Metric: 1, Bidirectional
Network *10.1.1.2 2.2.2.2 0x80000004 254 0x22 0x1404 32
mask 255.255.255.252
attached router 2.2.2.2
attached router 1.1.1.1
Topology default (ID 0)
Type: Transit, Node ID: 1.1.1.1
Metric: 0, Bidirectional
Type: Transit, Node ID: 2.2.2.2
Metric: 0, Bidirectional
Summary *2.2.2.2 2.2.2.2 0x80000004 2054 0x22 0xea3f 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 0
Summary *3.3.3.3 2.2.2.2 0x80000003 254 0x22 0xc85d 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 1
Summary *10.1.1.4 2.2.2.2 0x80000009 258 0x22 0x73ab 28
mask 255.255.255.252
Topology default (ID 0) -> Metric: 1
ASBRSum *3.3.3.3 2.2.2.2 0x80000003 254 0x22 0xba6a 28
mask 0.0.0.0
Topology default (ID 0) -> Metric: 1
OSPF database, Area 0.0.0.2
Type ID Adv Rtr Seq Age Opt Cksum Len
Router *2.2.2.2 2.2.2.2 0x80000010 258 0x22 0xad2a 48
bits 0x1, link count 2
id 10.1.1.6, data 10.1.1.5, Type Transit (2)
Topology count: 0, Default metric: 1
id 2.2.2.2, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.6
Metric: 1, Bidirectional
Router 3.3.3.3 3.3.3.3 0x80000012 259 0x22 0xc007 48
bits 0x2, link count 2
id 10.1.1.6, data 10.1.1.6, Type Transit (2)
Topology count: 0, Default metric: 1
id 3.3.3.3, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.6
Metric: 1, Bidirectional
Network 10.1.1.6 3.3.3.3 0x80000004 259 0x22 0x22e5 32
mask 255.255.255.252
attached router 3.3.3.3
attached router 2.2.2.2
Topology default (ID 0)
Type: Transit, Node ID: 2.2.2.2
Metric: 0, Bidirectional
Type: Transit, Node ID: 3.3.3.3
Metric: 0, Bidirectional
Summary *1.1.1.1 2.2.2.2 0x80000003 254 0x22 0x2509 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 1
Summary *10.1.1.0 2.2.2.2 0x80000003 1721 0x22 0xa781 28
mask 255.255.255.252
Topology default (ID 0) -> Metric: 1
OSPF AS SCOPE link state database
Type ID Adv Rtr Seq Age Opt Cksum Len
Extern 100.100.100.0 3.3.3.3 0x80000002 1292 0x22 0x86f1 36
mask 255.255.255.0
Topology default (ID 0)
Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
[edit]
lab# show logical-systems R3
interfaces {
em3 {
unit 23 {
vlan-id 23;
family inet {
address 10.1.1.6/30;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}
protocols {
ospf {
export STATIC2OSPF;
area 0.0.0.2 {
interface em3.23;
interface lo0.3;
}
}
}
policy-options {
policy-statement STATIC2OSPF {
from protocol static;
then accept;
}
}
routing-options {
static {
route 100.100.100.0/24 discard;
}
}
[edit]
lab# run show route logical-system R3
inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
1.1.1.1/32 *[OSPF/10] 00:05:44, metric 2
> to 10.1.1.5 via em3.23
2.2.2.2/32 *[OSPF/10] 00:05:49, metric 1
> to 10.1.1.5 via em3.23
3.3.3.3/32 *[Direct/0] 00:48:49
> via lo0.3
10.1.1.0/30 *[OSPF/10] 00:05:49, metric 2
> to 10.1.1.5 via em3.23
10.1.1.4/30 *[Direct/0] 00:06:30
> via em3.23
10.1.1.6/32 *[Local/0] 00:06:30
Local via em3.23
100.100.100.0/24 *[Static/5] 00:42:07
Discard
224.0.0.5/32 *[OSPF/10] 00:48:50, metric 1
MultiRecv
[edit]
lab# run show ospf database detail logical-system R3
OSPF database, Area 0.0.0.2
Type ID Adv Rtr Seq Age Opt Cksum Len
Router 2.2.2.2 2.2.2.2 0x80000010 362 0x22 0xad2a 48
bits 0x1, link count 2
id 10.1.1.6, data 10.1.1.5, Type Transit (2)
Topology count: 0, Default metric: 1
id 2.2.2.2, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.6
Metric: 1, Bidirectional
Router *3.3.3.3 3.3.3.3 0x80000012 361 0x22 0xc007 48
bits 0x2, link count 2
id 10.1.1.6, data 10.1.1.6, Type Transit (2)
Topology count: 0, Default metric: 1
id 3.3.3.3, data 255.255.255.255, Type Stub (3)
Topology count: 0, Default metric: 0
Topology default (ID 0)
Type: Transit, Node ID: 10.1.1.6
Metric: 1, Bidirectional
Network *10.1.1.6 3.3.3.3 0x80000004 361 0x22 0x22e5 32
mask 255.255.255.252
attached router 3.3.3.3
attached router 2.2.2.2
Topology default (ID 0)
Type: Transit, Node ID: 2.2.2.2
Metric: 0, Bidirectional
Type: Transit, Node ID: 3.3.3.3
Metric: 0, Bidirectional
Summary 1.1.1.1 2.2.2.2 0x80000003 358 0x22 0x2509 28
mask 255.255.255.255
Topology default (ID 0) -> Metric: 1
Summary 10.1.1.0 2.2.2.2 0x80000003 1825 0x22 0xa781 28
mask 255.255.255.252
Topology default (ID 0) -> Metric: 1
OSPF AS SCOPE link state database
Type ID Adv Rtr Seq Age Opt Cksum Len
Extern *100.100.100.0 3.3.3.3 0x80000002 1394 0x22 0x86f1 36
mask 255.255.255.0
Topology default (ID 0)
Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
Comments