BGP next-hop-unchanged

只要有學過或是設定過BGP指令的人一定知道有個neighbor參數叫做next-hop-self,這個參數最主要的目的是要讓IBGP原本不修改EBGP route next-hop參數的原則改變,讓其他的IBGP neighbor可以在沒有Edge Router WAN interface routing的情況下,直接forward packet給IBGP neighbor,而非直接forward packet給edge EBGP speaker。

而next-hop-unchanged這個參數則是剛好相反,它要讓特定網路環境中的next-hop保持不變,如EBGP宣告出去時,保持原有的next-hop,這樣的情況比較少見(通常是在RR/RR client連接至EBGP時,因為網路架構設計上的issue所導致)。不過如果是在EBGP neighbor IP皆屬於同一個子網路時,這個參數不用設定就會保持原有的next-hop了。

neighbor next-hop-unchanged
To enable an exterior BGP (eBGP) multihop peer to propagate the next hop unchanged, use the neighbor next-hop-unchanged command in address family or router configuration mode. To disable next hop propagation capabilities, use the no form of this command.

neighbor ip-address peer-group-name next-hop-unchanged
no neighbor ip-address peer-group-name next-hop-unchanged


Usage Guidelines
The neighbor next-hop-unchanged command is used to configured the propagate the next hop unchanged for multihop eBGP peering sessions. The neighbor next-hop-self command should not be used to modify the next hop attribute for a route reflector when this feature is enabled for a route reflector client.
This command can be used to perform the following tasks:
‧Bring the route reflector into the forwarding path, which can be used with the iBGP Multipath Load Sharing feature to configure load balancing.
‧Configure interprovider Multiprotocol Label Switching (MPLS) Virtual Private Networks (VPNs) by not modifying the next hop attribute when advertising routes to an eBGP peer.
‧Turn off the next hop calculation for an eBGP peer. This feature is useful for configuring the end-to-end connection of a label-switched path.

Examples
Route Reflector Configuration
The following example, starting in global configuration mode, configures the local router as a route reflector and configures the 10.0.0.100 multihop peer as a route reflector client. A route map is created to set the advertised next hop to 172.16.0.1.

route-map NEXTHOP
set ip next-hop 172.16.0.1
exit
!
router bgp 65535
address-family ipv4
neighbor 10.0.0.100 activate
neighbor 10.0.0.100 ebgp-multihop 255
neighbor 10.0.0.100 route-reflector-client
neighbor 10.0.0.100 route-map NEXTHOP out
end


Route Reflector Client Configuration
The following example, starting in global configuration mode, configures the local router (route-reflector client) to establish peering with the route reflector and to propagate the next hop unchanged:

router bgp 65412
address-family ipv4
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 ebgp-multihop 255
neighbor 192.168.0.1 next-hop-unchanged
end
1 comment

Popular posts from this blog

Pairwise Master Key (PMK) vs Parewise Transient Key(PTK) vs PseudoRandom Function(PRF) vs GTK (Groupwise Transient Key)

DSSS(直接序列展頻技術) vs OFDM(正交頻率多重分割)

DTMF Relay : RTP-NTE vs SIP INFO vs SIP NOTIFY