PPP Over Frame Relay

Feature Summary
The PPP over Frame Relay feature allows a router to establish end-to-end Point-to-Point Protocol (PPP) sessions over Frame Relay. IP datagrams are transported over the PPP link using RFC 1973 compliant Frame Relay framing. This feature is useful for remote users running PPP to access their Frame Relay corporate networks as shown in . shows a connectivity scenario using the Cisco 90i D4 channel card, which is capable of supporting Integrated Services Digital Network (ISDN) Digital Service Loop (DSL), PPP, or Frame Relay, which connects to an Internet Service Provider (ISP) or corporate network.

Figure 1


PPP Over Frame Relay Scenario

Figure 2 PPP over Frame Relay Using the Cisco 90i D4 Channel Unit



Benefits
PPP over Frame Relay provides the following benefits:
‧Allows end-to-end PPP sessions over Frame Relay.
‧Supports the 90i IDSL Channel Unit that supports both Frame Relay and Point-to-Point Protocol (PPP) on an ISDN DSL.

List of Terms
data-link connection identifier (DLCI)— A value that specifies a PVC or SVC in a Frame Relay network. In the basic Frame Relay specification, DLCIs are locally significant (connected devices might use different values to specify the same connection). In the LMI extended specification, DLCIs are globally significant (DLCIs specify individual end devices).
Integrated Services Digital Network (ISDN)—Communication protocols offered by telephone companies that permit telephone networks to carry data, voice, and other source traffic.
Link Control Protocol (LCP)—A protocol that establishes, configures, and tests data link connections used by PPP.
permanent virtual circuit (PVC)—Virtual circuit that is permanently established. PVCs save bandwidth associated with circuit establishment and tear down in situations where certain virtual circuits must exist all the time.
Point-to-Point Protocol (PPP)—A protocol that encapsulates network layer protocol information over point-to-point links. The RFC for PPP is RFC 1661.
virtual circuit (VC)—A logical circuit created to ensure reliable communication between two network devices. A virtual circuit can be either permanent (a PVC) or switched (an SVC). Virtual circuits are used in Frame Relay and X.25.

Restrictions
The following restrictions apply when using PPP over Frame Relay:
‧Only Frame Relay PVCs are supported.
‧Only the Internet Protocol (IP) is supported.

Platforms
This feature is supported on these platforms:
‧Cisco 1600 series
‧Cisco 2500 series
‧Cisco 2600 series
‧Cisco 3600 series
‧Cisco 4000 series (Cisco 4000, 4000-M, 4500, 4500-M, 4700, 4700-M)
‧Cisco 7200 series
‧Cisco 7500 series

Prerequisites
Before you can configure PPP over Frame Relay, Frame Relay must be enabled on the router using the encapsulation frame-relay command.

Functional Description
PPP over Frame Relay is compliant to the functionality and encapsulation specifications as outlined in RFC 1973. The frame format is shown in .
A PPP connection is established over the Frame Relay permanent virtual circuit (PVC). The PPP session does not occur unless the associated Frame Relay PVC is in an "active" state. The Frame Relay VC can coexist with other circuits using different Frame Relay encapsulation methods, such as RFC 1490 and Cisco proprietary, over the same Frame Relay link. There can be multiple PPP-in-Frame Relay circuits existing on one Frame Relay link.
One PPP connection resides on one virtual access interface, which is internally created from a virtual template interface. A virtual access interface is cloned from a virtual template interface. The virtual access interfaces is coexistent with the creation of the Frame Relay circuit when the corresponding DLCI is configured. One virtual template interface, containing all the necessary PPP and network protocol information is shared by multiple virtual access interfaces. Hardware compression and fancy queuing algorithms, such as weighted fair queuing, custom queuing, and priority queuing, are not applied to virtual access interfaces. Once a Frame Relay circuit is established using PPP over Frame Relay, all incoming and outgoing packets on this circuit are under RFC 1973 PPP-in-Frame-Relay encapsulation compliance until this DLCI is removed from the configuration. Refer to the Cisco IOS Release 11.3 Wide Area Configuration Guide and Command Reference documents for information about Frame Relay configuration options.

Figure 3 PPP over Frame Relay Frame Format


The breakdown of the Frame Relay frame format components is listed in .

Configuration Task
The only task required to implement PPP over Frame Relay is to configure the interface with the locally terminated PVC and the associated virtual template for PPP and IP, as described in the following section.

Enable PPP over Frame Relay
After you configure the Cisco router or access server for Frame Relay encapsulation, you must configure the physical interface with the PVC and apply a virtual template with PPP encapsulation to the DLCI that it applies to. To configure the physical interface that will carry the PPP session and link it to the appropriate virtual template interface, perform the following task in interface configuration mode:


Configuration Examples
This section provides the following examples:
PPP over Frame Relay DTE Example
PPP over Frame Relay DCE Example

PPP over Frame Relay DTE Example
The following example configures a router as a data terminating equipment (DTE) device for PPP over Frame Relay. Subinterface 2.1 contains the necessary DLCI and virtual template information. The virtual template interface (interface virtual-template 1) contains the PPP information that is applied to the PPP session associated with DLCI 32 on serial subinterface 2.1. Refer to the Cisco IOS Release 11.3 Wide-Area Configuration Guide and Wide-Area Networking Command Reference for information about Frame Relay configuration options.

interface serial 2
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface serial 2.1 point-to-point
frame-relay interface-dlci 32 ppp virtual-template1
!
interface Virtual-Template1
ip unnumbered ethernet 0
ppp authentication chap pap

Note:By default, the encapsulation type for a virtual template interface is PPP encapsulaiton; therefore, encapsulation ppp will not show up when viewing the router's configuration.

PPP over Frame Relay DCE Example
The following example configures a router to act as a data communications equipment (DCE) device. Typically, a router is configured for a DCE if connecting directly to another router or if connected to a 90i D4 channel unit, which is connected to a telco channel bank. The three commands required for this type of configuration are the frame-relay switching, frame-relay intf-type dce, and frame-relay route commands. In this configuration

frame-relay switching
!
interface Serial2/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 31 interface Serial1/2 100
frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial2/0:0.2 point-to-point
no ip address
frame-relay interface-dlci 40 ppp Virtual-Template2
!
interface Virtual-Template1
ip unnumbered Ethernet0/0
peer default ip address pool default
ppp authentication chap pap
!
interface Virtual-Template2
ip address 100.1.1.2 255.255.255.0
ppp authentication chap pap

Note:By default, the encapsulation type for a virtual template interface is PPP encapsulaiton; therefore, encapsulation ppp will not show up when viewing the router's configuration.
Post a Comment

Popular posts from this blog

Pairwise Master Key (PMK) vs Parewise Transient Key(PTK) vs PseudoRandom Function(PRF) vs GTK (Groupwise Transient Key)

DSSS(直接序列展頻技術) vs OFDM(正交頻率多重分割)

DTMF Relay : RTP-NTE vs SIP INFO vs SIP NOTIFY