何謂"Trunking"?

您知道三層交換機技術中常提到的TRUNK是什麼意思嗎?

在技術領域中把TRUNK翻譯為中文是“主幹、幹線、中繼線、長途線”,不過一般不翻譯,直接用原文。同樣的名詞在不同場合中有不同的解釋:

1、 在網路的分層結構和頻寬的分配方面,TRUNK被解釋為“端口匯聚”,是頻寬擴展和鏈路備份的一個重要途徑。TRUNK把多個物理端口捆綁在一起當作一個邏輯端口使用,可以把多組端口的頻寬累加起來使用。TRUNK技術可以實現TRUNK內部多條鏈路互為備份的功能,即當一條鏈路出現故障時,不影響其他鏈路的工作,同時多鏈路之間還能實現流量負載均衡。

2、在電信網路的語音級的線路中,Trunk指的是“主幹網路、電話幹線”,即兩個交換局或交換機之間的連接電路或信道,它能夠在兩端之間進行轉接,並提供必要的訊號和終端設備傳輸。

3、 在Routing & Switching領域中,VLAN的端口聚合有的叫TRUNK,不過大多數都叫TRUNKING ,如CISCO。所謂的TRUNKING是用來在不同的交換機之間進行連接,以保證在跨越多個交換機上建立的同一個VLAN的成員能夠相互通訊。其中交換機之間互聯用的端口就稱為TRUNK端口。

TRUNKING是基於OSI第二層技術,如果你在2個交換機上分別劃分了多個VLAN(VLAN也是基於Layer2的),那麼分別在兩個交換機上的VLAN10和VLAN20的各自的成員如果要互通,就需要在A交換機上設為VLAN10的端口中取一個和交換機B上設為VLAN10的某個端口利用一條實體線路相連接。

那麼如果交換機上設定了10個VLAN就需要分別使用10條實體線路來跟另一個交換機上10個不同VLAN的端口互相連結。相對來說使用效率低落而且管理不易。如果交換機支援TRUNKING的話,事情就簡單多了,只需要2個交換機之間有一條實體連線,並將對應的端口設置為Trunk,這條線路就可以承載交換機上所有VLAN的資訊。這樣的話,就算交換機上設了上百個個VLAN也只要用1個端口就可以解決了。

如果交換機上相同VLAN的主機要相互通信,那麼可以通過共用的trunk端口就可以實現;如果是不同VLAN的主機之間要相互通信,就必需要通過第三方的路由功能的設備來實現。這也就是所謂的Inter-VLAN Routing。

【例】假設有兩個VLAN,分別為VLAN 1(Switch F0/2),VLAN 2(Switch F0/3),在F0/2跟F0/3上各接了一台主機,VLAN 1(192.168.0.0/24)、VLAN 2(192.168.1.0/24)分屬於不同網段;此時就需要有一台具有路由功能的設備(如Router)來負責進行Inter-VLAN Routing:將Router及Switch使用Trunking(IEEE 802.1Q or Cisco ISL,本例中使用IEEE 802.1Q)方式對接,然後在Router上設定sub-interface對應相對的VLAN。

Router F0/0 - <802.1q/ISL Trunk> - Switch F0/1
F0/2接PC1
F0/3接PC2

在Router Trunk port上設定sub-interface對應同一個VLAN的ip address當成VLAN1, VLAN2的GW

Router:
int f0/0
ip address 192.168.0.254 255.255.255.0

int f0/0.2
encapsulation dot1q 2
ip address 192.168.1.254 255.255.255.0

Switch:
int f0/1
switchport trunk encapsulation dot1q (Cat.2950 不用打此指令)
switchport mode trunk

int f0/2
switchport mode access
switchport access vlan 1

int f0/3
switchport mode access
switchport access vlan 2
Post a Comment

Popular posts from this blog

Pairwise Master Key (PMK) vs Parewise Transient Key(PTK) vs PseudoRandom Function(PRF) vs GTK (Groupwise Transient Key)

DSSS(直接序列展頻技術) vs OFDM(正交頻率多重分割)

DTMF Relay : RTP-NTE vs SIP INFO vs SIP NOTIFY